Red card no showing when red filter is in place

Report a MTG Studio bug you have spotted or ask for help

Moderator: gaddlord

Red card no showing when red filter is in place

Postby lombas » Sat Aug 13, 2011 2:22 pm

If I filter the card pool to show only red cards, "Crookshank Kobolds" (http://magiccards.info/lg/en/220.html), a red cards, doesn't shows up. If I remove the filter the card shows up in the pool.

That's it.

Thanks
User avatar
lombas
Mage
Mage
 
Posts: 15
Joined: Sun Jul 24, 2011 9:09 pm

Postby OldGreen » Sat Aug 27, 2011 12:25 am

I have the same problem. If you look at the way the filters work (in the advanced filter dialog) it uses the mana cost of the card to filter color, not the rules text. Transguild Courier should have the same problem.
OldGreen
Sorcerer
Sorcerer
 
Posts: 30
Joined: Tue May 17, 2011 11:08 pm

Postby gaddlord » Fri Sep 02, 2011 11:24 am

OldGreen's comment is right. Color filtering is done over the Mana Cost.

Parsing Rules is a non-trivial task. The only optimal (ion terms of speed) way to do it if I finally get the time to finish my taxonomy for the card rules and you filter by the Ability: Red Cards.

Feel free to vote for this feature at http://mtgstudio.uservoice.com/forums/16948-mtg-studio-suggestions/suggestions/1616743-add-all-cards-to-abilities?ref=title.
GET LATEST STABLE http://www.mtgstudio.com/download.aspx
Send feature requests and bugs to gaddlord@mtgstudio.com or vote online.
User avatar
gaddlord
MTG Studio Team
MTG Studio Team
 
Posts: 2945
Joined: Thu Dec 18, 2003 12:01 pm
Location: Europe


Return to Bugs (MTG Studio)

Who is online

Users browsing this forum: No registered users and 1 guest