MTG Studio will not open...I instead get an exception error

Report a MTG Studio bug you have spotted or ask for help

Moderator: gaddlord

MTG Studio will not open...I instead get an exception error

Postby dyank69 » Thu Jul 14, 2011 9:15 pm

I'm not sure if this is due to my moving my files to another hard drive as the old one was dying, but I can no longer access MTG Studio. This is the error I get now when I try to start it.

Any ideas on how to fix?

Thanks,

Steve

---------------------------
MTG Studio
---------------------------
19:42:42,671(+3250) X [T3680] MTG Studio (version 2.1.0.3102) encountered exeptional situation.



You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com.

Please also provide the steps to reproduce the problem you have encountered.



Exception: EInvalidOp

Sender: nil

Address: $DBCE21

Message: Invalid floating point operation

Help Context: 0

Thread: thread $e60


---------------------------
OK
---------------------------
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm

Postby gaddlord » Sun Jul 17, 2011 4:33 pm

There should be a more detailed error dialog displayed. Do you see such with options to view details and send them as email?
GET LATEST STABLE http://www.mtgstudio.com/download.aspx
Send feature requests and bugs to gaddlord@mtgstudio.com or vote online.
User avatar
gaddlord
MTG Studio Team
MTG Studio Team
 
Posts: 2938
Joined: Thu Dec 18, 2003 12:01 pm
Location: Europe

Postby dyank69 » Sun Jul 17, 2011 7:54 pm

date/time : 2011-07-17, 19:51:57, 984ms
computer name : STEVE-WX6612J2V
user name : steve <admin>
registered owner : steve
operating system : Windows XP Service Pack 3 build 2600
system language : English
system up time : 2 days 23 hours
program up time : 5 seconds
processor : AMD Athlon(tm) XP 1800+
physical memory : 1116/2015 MB (free/total)
free disk space : (C:) 102.36 GB
display mode : 1024x768, 32 bit
process id : $884
allocated memory : 32.46 MB
executable : mtgstudio.exe
exec. date/time : 2011-06-27 13:03
version : 2.1.0.3102
compiled with : Delphi compiler version 22.0
madExcept version : 3.0l
callstack crc : $3d7b7616, $ac3fa0a7, $ac3fa0a7
count : 8
exception number : 1
exception class : EInvalidOp
exception message : Invalid floating point operation.

main thread ($bd8):
3d7b7616 +000 jscript.dll
7e418a0b +00a USER32.dll DispatchMessageW
00999d0b +0f3 mtgstudio.exe Forms TApplication.ProcessMessage
00999d4e +00a mtgstudio.exe Forms TApplication.HandleMessage
009956ad +1a1 mtgstudio.exe Forms TCustomForm.ShowModal
7c915196 +043 ntdll.dll bsearch

thread $a0c:
7c90df48 +a ntdll.dll NtWaitForMultipleObjects

thread $e74:
7c90daa8 +a ntdll.dll NtReplyWaitReceivePortEx

thread $df4:
7c90d218 +0a ntdll.dll NtDelayExecution
7c8023eb +4b kernel32.dll SleepEx
7c802450 +0a kernel32.dll Sleep
7c910432 +25 ntdll.dll RtlAcquirePebLock

thread $ba4: <priority:15>
7c90df48 +0a ntdll.dll NtWaitForMultipleObjects
7c80958a +00 kernel32.dll WaitForMultipleObjectsEx
7c80a110 +13 kernel32.dll WaitForMultipleObjects

thread $d9c: <priority:2>
7e427766 +03b USER32.dll GetMessageA
7c915196 +043 ntdll.dll bsearch
00856f81 +00d mtgstudio.exe madExcept CallThreadProcSafe
00856feb +037 mtgstudio.exe madExcept ThreadExceptFrame
7c915196 +043 ntdll.dll bsearch
>> created by main thread ($bd8) at:
76b448a6 +257 WINMM.dll PlaySoundW

thread $c08:
7e42a436 +f6 USER32.dll PeekMessageA

thread $ce0:
7c90d218 +a ntdll.dll NtDelayExecution

thread $15c:
7c90da48 +a ntdll.dll NtRemoveIoCompletion

thread $5dc:
7c90df58 +0a ntdll.dll NtWaitForSingleObject
7c8025d5 +85 kernel32.dll WaitForSingleObjectEx
7c80253d +0d kernel32.dll WaitForSingleObject
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm

Postby dyank69 » Thu Jul 21, 2011 10:53 pm

Just wondering if there's been any luck on a resolution, I'd love to continue using the program, even though I definitely feel I got my money's worth out of it.
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm

Postby gaddlord » Fri Jul 22, 2011 5:34 am

The error is pretty odd being in jscript.dll.

What I can advise is to try to delete your Configuration folder (details where it is on http://mtgstudio.com/wiki/index.php?[CENSORED] ... _Structure)

and also try to change your Decimal Separator to "." (dot) from Control Panel regional settings

Image
GET LATEST STABLE http://www.mtgstudio.com/download.aspx
Send feature requests and bugs to gaddlord@mtgstudio.com or vote online.
User avatar
gaddlord
MTG Studio Team
MTG Studio Team
 
Posts: 2938
Joined: Thu Dec 18, 2003 12:01 pm
Location: Europe

Postby dyank69 » Sun Jul 24, 2011 12:31 am

ok, so after deleting the configuration folder, it gave me this error and bug report:

date/time : 2011-07-24, 00:29:08, 218ms
computer name : STEVE-WX6612J2V
user name : steve <admin>
registered owner : steve
operating system : Windows XP Service Pack 3 build 2600
system language : English
system up time : 13 hours 28 minutes
program up time : 8 seconds
processor : AMD Athlon(tm) XP 1800+
physical memory : 1120/2015 MB (free/total)
free disk space : (C:) 102.13 GB
display mode : 1024x768, 32 bit
process id : $dec
allocated memory : 32.44 MB
executable : mtgstudio.exe
exec. date/time : 2011-06-27 13:03
version : 2.1.0.3102
compiled with : Delphi compiler version 22.0
madExcept version : 3.0l
callstack crc : $3d7b7616, $ac3fa0a7, $ac3fa0a7
count : 9
exception number : 1
exception class : EInvalidOp
exception message : Invalid floating point operation.

main thread ($d34):
3d7b7616 +000 jscript.dll
7e418a0b +00a USER32.dll DispatchMessageW
00999d0b +0f3 mtgstudio.exe Forms TApplication.ProcessMessage
00999d4e +00a mtgstudio.exe Forms TApplication.HandleMessage
009956ad +1a1 mtgstudio.exe Forms TCustomForm.ShowModal
7c915196 +043 ntdll.dll bsearch

thread $30c:
7c90df48 +a ntdll.dll NtWaitForMultipleObjects

thread $fc0:
7c90daa8 +a ntdll.dll NtReplyWaitReceivePortEx

thread $590:
7c90d218 +0a ntdll.dll NtDelayExecution
7c8023eb +4b kernel32.dll SleepEx
7c802450 +0a kernel32.dll Sleep
7c910432 +25 ntdll.dll RtlAcquirePebLock

thread $58c:
7c90d218 +0a ntdll.dll NtDelayExecution
7c8023eb +4b kernel32.dll SleepEx
7c802450 +0a kernel32.dll Sleep

thread $894: <priority:15>
7c90df48 +0a ntdll.dll NtWaitForMultipleObjects
7c80958a +00 kernel32.dll WaitForMultipleObjectsEx
7c80a110 +13 kernel32.dll WaitForMultipleObjects

thread $b8: <priority:2>
7e427766 +03b USER32.dll GetMessageA
7c915196 +043 ntdll.dll bsearch
00856f81 +00d mtgstudio.exe madExcept CallThreadProcSafe
00856feb +037 mtgstudio.exe madExcept ThreadExceptFrame
7c915196 +043 ntdll.dll bsearch
>> created by main thread ($d34) at:
76b448a6 +257 WINMM.dll PlaySoundW

thread $ecc:
7c90d218 +a ntdll.dll NtDelayExecution

thread $ce4:
7c90da48 +a ntdll.dll NtRemoveIoCompletion

thread $c5c:
7c90df58 +0a ntdll.dll NtWaitForSingleObject
7c8025d5 +85 kernel32.dll WaitForSingleObjectEx
7c80253d +0d kernel32.dll WaitForSingleObject
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm

Postby dyank69 » Tue Jul 26, 2011 9:55 pm

So I installed ver 2.2 today, and it still won't start. Here's the error log.

date/time : 2011-07-26, 21:52:29, 75ms
computer name : STEVE-WX6612J2V
user name : steve <admin>
registered owner : steve
operating system : Windows XP Service Pack 3 build 2600
system language : English
system up time : 2 days
program up time : 5 seconds
processor : AMD Athlon(tm) XP 1800+
physical memory : 1251/2015 MB (free/total)
free disk space : (C:) 102.05 GB
display mode : 1024x768, 32 bit
process id : $9b8
allocated memory : 33.57 MB
executable : mtgstudio.exe
exec. date/time : 2011-07-26 14:19
version : 2.2.0.3109
compiled with : Delphi compiler version 22.0
madExcept version : 3.0l
callstack crc : $3d7b7616, $ca460f1e, $ca460f1e
exception number : 1
exception class : EInvalidOp
exception message : Invalid floating point operation.

main thread ($8fc):
3d7b7616 +000 jscript.dll
7e418a0b +00a USER32.dll DispatchMessageW
00999d47 +0f3 mtgstudio.exe Forms TApplication.ProcessMessage
00999d8a +00a mtgstudio.exe Forms TApplication.HandleMessage
009956e9 +1a1 mtgstudio.exe Forms TCustomForm.ShowModal
0142ed1e +0a6 mtgstudio.exe frm_LicAgreement TfrmLicenseAgreement.ShowDialog
0143f0f2 +056 mtgstudio.exe unt_MtgStudio LoadConfiguration
0143fcce +8d6 mtgstudio.exe unt_MtgStudio TMtgStudio.Start
0147a374 +010 mtgstudio.exe mtgstudio 366 +1 initialization
7c915196 +043 ntdll.dll bsearch

thread $304:
7c90df48 +a ntdll.dll NtWaitForMultipleObjects

thread $8b0:
7c90daa8 +a ntdll.dll NtReplyWaitReceivePortEx

thread $aa0:
7c90d218 +0a ntdll.dll NtDelayExecution
7c8023eb +4b kernel32.dll SleepEx
7c802450 +0a kernel32.dll Sleep
7c910432 +25 ntdll.dll RtlAcquirePebLock

thread $cbc: <priority:15>
7c90df48 +0a ntdll.dll NtWaitForMultipleObjects
7c80958a +00 kernel32.dll WaitForMultipleObjectsEx
7c80a110 +13 kernel32.dll WaitForMultipleObjects

thread $9a0: <priority:2>
7e427766 +03b USER32.dll GetMessageA
7c915196 +043 ntdll.dll bsearch
00856f81 +00d mtgstudio.exe madExcept CallThreadProcSafe
00856feb +037 mtgstudio.exe madExcept ThreadExceptFrame
7c915196 +043 ntdll.dll bsearch
>> created by main thread ($8fc) at:
76b448a6 +257 WINMM.dll PlaySoundW

thread $6bc:
7c90d218 +0a ntdll.dll NtDelayExecution
7c8023eb +4b kernel32.dll SleepEx
7c802450 +0a kernel32.dll Sleep

thread $e04:
7c90d218 +a ntdll.dll NtDelayExecution

thread $ca0:
7c90da48 +a ntdll.dll NtRemoveIoCompletion

thread $e6c:
7c90df58 +0a ntdll.dll NtWaitForSingleObject
7c8025d5 +85 kernel32.dll WaitForSingleObjectEx
7c80253d +0d kernel32.dll WaitForSingleObject

Any other suggestions, Gaddlord?
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm

Postby gaddlord » Wed Jul 27, 2011 10:33 am

This happens on the very first start of MTG Studio. It tries to open the license agreement confirmation form which is displayed within an embedded Internet Explorer. The error is raised by the JScript.dll which is used to process Java Script oddly enough the License Agreement does not contain much of a Java Script code.

Which Internet Explorer version you are using and is Java Script enabled in it?
GET LATEST STABLE http://www.mtgstudio.com/download.aspx
Send feature requests and bugs to gaddlord@mtgstudio.com or vote online.
User avatar
gaddlord
MTG Studio Team
MTG Studio Team
 
Posts: 2938
Joined: Thu Dec 18, 2003 12:01 pm
Location: Europe

Postby dyank69 » Wed Jul 27, 2011 10:29 pm

I'm using IE8, although I never use IE, so it may not be up to date. As far as I can tell, javascript is enabled on IE. I checked via Tools>Internet Options>Advanced tab. Is there somewhere else I should be checking? Could it be that my jscript.dll is corrupted somehow? I'm not having problems with anything else.
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm

Postby gaddlord » Mon Aug 01, 2011 8:09 am

It is likely that this is a Floating Point error not present on all CPUs. I have uploaded a potential fix version at http://www.mtgstudio.com/download/beta/mtgstudio.exe

Please

1. Download
2. Backup your mtgstudio.exe
3. Overwrite with the downloaded files
4. Run MTG Studio again
5. Report on success/failure in the forum.
GET LATEST STABLE http://www.mtgstudio.com/download.aspx
Send feature requests and bugs to gaddlord@mtgstudio.com or vote online.
User avatar
gaddlord
MTG Studio Team
MTG Studio Team
 
Posts: 2938
Joined: Thu Dec 18, 2003 12:01 pm
Location: Europe

Postby dyank69 » Mon Aug 01, 2011 10:19 pm

ok, with a little work (nothing serious), I have MTG Studio working again! YEAH! For whatever reason, my collection has been wiped out though. I went through the backup, it is empty as well. Not a huge loss, however, I haven't been able to update it in a while so re-entering was going to have to happen anyways.

Thanks again for your hard work, Gaddlord. I really do appreciate it!
dyank69
Apprentice
 
Posts: 8
Joined: Tue Jul 12, 2011 7:41 pm


Return to Bugs (MTG Studio)

Who is online

Users browsing this forum: No registered users and 2 guests

cron