Card filtering issues

Report a MTG Studio bug you have spotted or ask for help

Moderator: gaddlord

Card filtering issues

Postby Braveheartfan » Sat Mar 05, 2011 2:56 pm

I am having trouble with the card filtering. Everytime I try to filter the master database by editions, the program stops responding and I have to go into Windows taskmanager to stop it. I set up an advanced filter and managed to make it work sometimes to filter out certain sets. Even the advanced filter causes the program to stop responding about half the time. If I try to do a search for something with the advanced filter active (Like search for any black cards with knight in them) the program stops responding. :cry: The filtering seems to take a long time, too. It's weird. Everything else seems to work ok, except for the search window in the task bar which I know others have issues with too.

I am running Studio on a new laptop running Windows 7 64x, 6gb ram. It should run no problems. I am running the last public release from September and not any of the Beta versions. I've been just waiting for the beta issues to be resolved and the final version released before trying it out.

Anyone else having these issues or have solutions? Maybe the beta release with the smaller database will help.
This isn't going to hurt. It's going to leave an emotional scar.....
Braveheartfan
Sorcerer
Sorcerer
 
Posts: 25
Joined: Sat Mar 05, 2011 12:49 pm
Location: Maine

Postby Percivul » Sat Mar 05, 2011 5:27 pm

You may want to try running the problem in compatibility mode for the time being. I had a similar issue and when I changed to compatibility mode, it seemed to clear it up.

Cheers
Percivul
Mage
Mage
 
Posts: 19
Joined: Tue Feb 22, 2011 2:39 am

Postby Braveheartfan » Sun Mar 06, 2011 2:56 pm

I just tried compatibility mode. I tried running as administrator. Nothing seems to help. As soon as I click OK or Apply in the filter window, the program stops responding.

When I try the advanced filter, the same thing happens except that after a minute or so the program usually does filter and displays. It seems to work somewhat but is very slow.

Using the regular filter just won't work for some reason. Neither filter really works correctly at this point. Strange problem that doesn't seem to be an issue for many.

Any other ideas as to what could be causing this?
This isn't going to hurt. It's going to leave an emotional scar.....
Braveheartfan
Sorcerer
Sorcerer
 
Posts: 25
Joined: Sat Mar 05, 2011 12:49 pm
Location: Maine

Postby Braveheartfan » Sun Mar 06, 2011 3:13 pm

After further experimentation, I can make the filter work to filter editions. I still had search parameters in the other window for terms and colors. I thought I had cleared them but they were remembered for some reason. Once I cleared these out I can get the filter to filter the editions properly. It's a bit slow but works. After I have the editions filtered, then I can go search for whatever (like Knights, in white cards, etc) and it works fine. Maybe it was just going to take a long time to filter the other way and hadn't actually stopped responding as Windows thought. The program still shows not responding while the editions filter but after about 30 seconds, they are filtered and everything seems fine. So, I guess this was mostly my fault. Still trying to figure out everything.................. :lol:
This isn't going to hurt. It's going to leave an emotional scar.....
Braveheartfan
Sorcerer
Sorcerer
 
Posts: 25
Joined: Sat Mar 05, 2011 12:49 pm
Location: Maine

Postby gaddlord » Sun Mar 06, 2011 3:32 pm

Can you try this on the Beta 7 version, mate. I believe it should be faster in times compared to 1.8.2 version.

It is highly likely that the problem is resolved in 1.8.3 since the whole database engine has been changed in the background.
GET LATEST STABLE http://www.mtgstudio.com/download.aspx
Send feature requests and bugs to gaddlord@mtgstudio.com or vote online.
User avatar
gaddlord
MTG Studio Team
MTG Studio Team
 
Posts: 2938
Joined: Thu Dec 18, 2003 12:01 pm
Location: Europe


Return to Bugs (MTG Studio)

Who is online

Users browsing this forum: No registered users and 1 guest

cron