MTG Studio 1.8.3 Beta 3 Released

General ideas, features requests, comments, concerns, complaints about MTG Studio desktop application

Moderator: gaddlord

Postby Laserdan » Mon Feb 21, 2011 7:19 pm

doent work...db not compatable...

so either SoM or MBS but not both in this beta...hmm tough choice.
Laserdan
Sorcerer
Sorcerer
 
Posts: 28
Joined: Tue Dec 14, 2010 4:18 pm

Re: No SoM in 1.8.3 beta 3 build 2991

Postby Schwanke » Mon Feb 21, 2011 7:23 pm

Laserdan wrote:Should i go install the 1.8.2.1 SoM patch or not?


Looks like the version at the tpo of this thread doesnt have SOM but if you DO install 1.8.2.1 patch into the 1.8.3 directory it eats it. :/ The error is:

Code: Select all
---------------------------
mtgstudio
---------------------------
19:43:13,375(+ 459) X [T2044] mtgstudio (version 1.8.3.2991) encountered exeptional situation.



You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com.

Please also provide the steps to reproduce the problem you have encountered.



Exception: Exception

Sender: nil

Address: $C29981

Message: Invalid database file format.

Help Context: 0


---------------------------
OK   
---------------------------


Which I am sure doesnt really matter since this was a hack attempt anyway and isnt something someone should be doing on purpose but hey I like experimenting.

Installing 1.8.3 again from this thread fixed it back to the normal but still lacking SOM state.

So I guess Gad will have to release a 1.8.3.1 SOM patch for the new 1.8.3 install?
Newest version of the software, beta or otherwise can be found here: http://www.mtgstudio.com/forum/viewforum.php?f=2
---
My detailed Pricing Feature Suggestions: http://www.mtgstudio.com/forum/viewtopic.php?t=1455
Schwanke
Planeswalker
Planeswalker
 
Posts: 264
Joined: Thu Jul 15, 2010 6:49 pm

Postby Weevil » Tue Feb 22, 2011 1:51 am

FOR THOSE SEEING THE "DATABASE IS NOT COMPATIBLE" ERROR MESSAGE:

It likely means that you installed an earlier version of the 1.8.3 beta (pre Besieged). If so, you likely have your collection file stored here: C:\Users\<username>\AppData\Roaming\PalmROOT\MTG Studio 1.8.3. You will need to move it out of here before installing the latest beta because the format is not compatible with the new engine. After you've installed the latest Beta, you can then Import your old collection and it should work ok.

Well, other than the fact that you can't add any Scars of Mirrodin cards right now because the set no longer shows up in the card pool...
Weevil
Wizard
Wizard
 
Posts: 57
Joined: Tue Dec 21, 2010 2:56 am
Location: Issaquah, WA

Postby scarecrowmagick » Tue Feb 22, 2011 1:55 am

Yes, and updating prices is a bit tricky. So far I haven't succeeded. I look forward to the time when it does work. This software is going to ROCK.
If there's anything I can do to help, it's time to panic.
scarecrowmagick
Sorcerer
Sorcerer
 
Posts: 22
Joined: Thu Jan 27, 2011 10:23 pm
Location: Sultan, WA

Postby Moobu » Tue Feb 22, 2011 2:57 am

scarecrowmagick wrote:Yes, and updating prices is a bit tricky. So far I haven't succeeded. I look forward to the time when it does work. This software is going to ROCK.


Yes can someone clarify how to update prices? Currently I have no prices and the little button in the price cell tells me to update my price lists. Where would I go to do this?
Moobu
Sorcerer
Sorcerer
 
Posts: 23
Joined: Mon Jan 31, 2011 3:11 am

Postby Schwanke » Tue Feb 22, 2011 6:45 am

Oh a correction to a previous post of mine. You dont need to update your key it keeps the old info. Forgot that I had reinstalled my whole OS on that machine. I didnt update the key on my desktop and my desktop still is registered.

For those that are running out of demo time and having problems. I would contact gad asking if he would mind extending it and he might be able to walk you through how. I know there are ways but for obvios reasons I wont elaborate here. And no I cant gaurentee Gad would even say yes but he is an nice guy. :)
Newest version of the software, beta or otherwise can be found here: http://www.mtgstudio.com/forum/viewforum.php?f=2
---
My detailed Pricing Feature Suggestions: http://www.mtgstudio.com/forum/viewtopic.php?t=1455
Schwanke
Planeswalker
Planeswalker
 
Posts: 264
Joined: Thu Jul 15, 2010 6:49 pm

Postby Schwanke » Tue Feb 22, 2011 6:46 am

Moobu wrote:
scarecrowmagick wrote:Yes, and updating prices is a bit tricky. So far I haven't succeeded. I look forward to the time when it does work. This software is going to ROCK.


Yes can someone clarify how to update prices? Currently I have no prices and the little button in the price cell tells me to update my price lists. Where would I go to do this?


When the collection pane is open you can go to the menu and at the bottom of I think file is 'update prices' however I just did that and got this error:

Code: Select all
---------------------------
MTG Studio
---------------------------
07:09:52,852(+26380) X [T6180] MTG Studio (version 1.8.3.2991) encountered exeptional situation.



You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com.

Please also provide the steps to reproduce the problem you have encountered.



Exception: EVariantInvalidOpError

Sender: TfrmProgress in [frm_Progress]

Address: $C29981

Message: Invalid variant operation

Help Context: 0


---------------------------
OK   
---------------------------
Newest version of the software, beta or otherwise can be found here: http://www.mtgstudio.com/forum/viewforum.php?f=2
---
My detailed Pricing Feature Suggestions: http://www.mtgstudio.com/forum/viewtopic.php?t=1455
Schwanke
Planeswalker
Planeswalker
 
Posts: 264
Joined: Thu Jul 15, 2010 6:49 pm

Postby TheAndrian » Tue Feb 22, 2011 1:05 pm

Well tried to reinstall the new beta after my earlier problems - uninstalled earlier version etc and wiped all the files from roaming etc with my original backed up collection file put aside before any installations of the new beta

Ran the reinstalled beta - get the usual error that the file is not compatible then imported the original collection file everything seems fine the import reports 0 fails. Then I close the app and restart it and loading complains with the following error:

MTG Studio
---------------------------
17:40:23,066(+1766) X [T4332] MTG Studio (version 1.8.3.2991) encountered exeptional situation. You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com. Please also provide the steps to reproduce the problem you have encountered. Exception: EVariantTypeCastError Sender: frmDecker in [frm_Decker] Address: $C29981 Message: Could not convert variant of type (Null) into type (OleStr) Help Context: 0
---------------------------
OK
---------------------------

click ok and then the option to continue, restart etc or close the app - I select continue and the following error appears:


---------------------------
MTG Studio
---------------------------
17:41:02,284(+3360) X [T1884] MTG Studio (version 1.8.3.2991) encountered exeptional situation. You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com. Please also provide the steps to reproduce the problem you have encountered. Exception: EAccessViolation Sender: TcxGridFooterCellViewInfo in [cxGridTableView] Address: $C29981 Message: Access violation at address 0087F02E in module 'mtgstudio.exe'. Write of address 3EEA2AD1 Help Context: 0
---------------------------
OK
---------------------------

In the end I close the app completely from the options presented.

Try to load the app again the first mentioned error appears and click ok and select continue now another error appears as follows:

---------------------------
MTG Studio
---------------------------
18:02:36,958(+4419) X [T5628] MTG Studio (version 1.8.3.2991) encountered exeptional situation.



You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com.

Please also provide the steps to reproduce the problem you have encountered.



Exception: EAccessViolation

Sender: frmSplash in [frm_Splash]

Address: $C29981

Message: Access violation at address 00A0AA7C in module 'mtgstudio.exe'. Write of address 00000001

Help Context: 0


---------------------------
OK
---------------------------

This is getting really weird - I just can't fathom whats going on - the only thing I can think of is that it goes buggy after the old version collection file has been imported.

Cheers
TheAndrian
Wizard
Wizard
 
Posts: 56
Joined: Wed Oct 07, 2009 11:35 am

Postby jradford » Wed Feb 23, 2011 6:21 pm

Well, here is my error:

---------------------------
MTG Studio
---------------------------
18:20:47,014(+ 256) X [T4404] MTG Studio (version 1.8.3.2991) encountered exeptional situation.



You can copy this error message by pressing Ctrl+C, and paste it in an email to support@mtgstudio.com.

Please also provide the steps to reproduce the problem you have encountered.



Exception: Exception

Sender: nil

Address: $C29981

Message: Invalid database file format.

Help Context: 0


---------------------------
OK
---------------------------

Win 7 - 64 bit. Made sure I removed 1.8.3 folders before install.
jradford
Sorcerer
Sorcerer
 
Posts: 35
Joined: Thu Jan 27, 2011 9:38 am

Postby Moobu » Thu Feb 24, 2011 12:11 pm

Jradford that problem has been addressed earlier in the forum. Look for the post on this page detailing going into the users folder and deleting your old installation files.
Moobu
Sorcerer
Sorcerer
 
Posts: 23
Joined: Mon Jan 31, 2011 3:11 am

Postby jradford » Thu Feb 24, 2011 1:12 pm

Moobu wrote:Jradford that problem has been addressed earlier in the forum. Look for the post on this page detailing going into the users folder and deleting your old installation files.


I did that. I deleted the 1.8.3 folders and did the install again with the same result. Before I did that, I tried removing the old though add/remove programs (then deleted the folders manually).

Do I need to remove 1.8.2 completely also? Just make a backup of my .collection file before?
jradford
Sorcerer
Sorcerer
 
Posts: 35
Joined: Thu Jan 27, 2011 9:38 am

Postby Moobu » Thu Feb 24, 2011 3:33 pm

jradford wrote:
I did that. I deleted the 1.8.3 folders and did the install again with the same result. Before I did that, I tried removing the old though add/remove programs (then deleted the folders manually).

Do I need to remove 1.8.2 completely also? Just make a backup of my .collection file before?

I didn't have to. Make sure you get your program files folder and the users folder (if you don't see it its because you need to check see hidden folders in your folders options). Removing the hidden files in the users folder is what made that error go away. Honestly though I'm still just using 1.8.2 because 1.8.3's prices are broken and scars of mirrodin is missing and MBS is there. Upgrading to 1.8.3 is only taking 1 step forward and 2 steps back.

TLDR: Wait for 1.8.4 because 1.8.3 is less functional than 1.8.2
Moobu
Sorcerer
Sorcerer
 
Posts: 23
Joined: Mon Jan 31, 2011 3:11 am

Postby jradford » Thu Feb 24, 2011 3:43 pm

Moobu wrote:
jradford wrote:
I did that. I deleted the 1.8.3 folders and did the install again with the same result. Before I did that, I tried removing the old though add/remove programs (then deleted the folders manually).

Do I need to remove 1.8.2 completely also? Just make a backup of my .collection file before?

I didn't have to. Make sure you get your program files folder and the users folder (if you don't see it its because you need to check see hidden folders in your folders options). Removing the hidden files in the users folder is what made that error go away. Honestly though I'm still just using 1.8.2 because 1.8.3's prices are broken and scars of mirrodin is missing and MBS is there. Upgrading to 1.8.3 is only taking 1 step forward and 2 steps back.

TLDR: Wait for 1.8.4 because 1.8.3 is less functional than 1.8.2


Yeah, I think I will just keep plugging away entering cards into 1.8.2 Still have about 5000 cards to enter in. Little over half way there. Oh, for the second time. :)
jradford
Sorcerer
Sorcerer
 
Posts: 35
Joined: Thu Jan 27, 2011 9:38 am

legality

Postby phareux » Thu Feb 24, 2011 7:44 pm

i notice that no MBS cards show up as legal in any format. i am relativity new to the format system so i don not know if this correct or not.
phareux
Mage
Mage
 
Posts: 17
Joined: Tue Jul 13, 2010 7:06 pm

Re: legality

Postby Ouronos » Fri Feb 25, 2011 1:03 am

phareux wrote:i notice that no MBS cards show up as legal in any format. i am relativity new to the format system so i don not know if this correct or not.


Greetings...

This is *not* correct, MBS is, indeed, legal in Standard format (and, as such, also in Extended format).

MBS working is not complete in the Beta, so there are still lots of little things that should be getting fixed for Beta 4; or so I would hope. :)

Until that time...
Until that time...
-Sir Gawain Ouronos

The Rose may wilt...
...but cannot die.
...for The Rose doth live in us all.
User avatar
Ouronos
Registered User
Registered User
 
Posts: 62
Joined: Thu Jun 29, 2006 3:35 pm
Location: Kansas City, KS

PreviousNext

Return to General Discussions (MTG Studio)

Who is online

Users browsing this forum: No registered users and 3 guests

cron